You should update your iPhone software right now. Here’s why


iPhone users are facing a software vulnerability that independent researchers say was used to spy on a Saudi activist. On Monday, Apple issued an urgent update to fix the issue.

The company’s head of security engineering said in a statement that the vulnerability is used to target specific individuals and is “not a threat to the overwhelming majority of our users.” But it’s particularly dangerous because it opens the door to being hacked without users having to click on a corrupted link, as is the case with most other cyberattacks.

And it can affect anyone who uses iMessage.

Apple issues urgent iPhone software update to address critical spyware vulnerability

Now, iPhone users can update their phones to iOS 14.8 to be protected from potential attacks. It’s as simple as going to your settings, clicking on “General” and checking the field that says “Software Update.”

There has been a proliferation of so-called “zero click” attacks in recent months, largely believed to be enabled by spyware from Israeli firm NSO Group. The firm says it only sells its services to government agencies in order to combat terrorism and crime.

In a statement on Monday, NSO Group did not address the allegations, only saying it “will continue to provide intelligence and law enforcement agencies around the world with life saving technologies to fight terror and crime.”

Researchers, however, say they have found multiple cases in which the spyware was deployed on dissidents or journalists. And the increasing prevalence of attacks that can infiltrate devices without the user’s knowledge or involvement mean keeping your phone’s software up to date has never been more important.



Source link

Spread the love

Written by bourbiza

3 best Mumbai Indian knocks in the first leg of the tournament

Where are the Taliban’s missing leaders? Rumors swirl over fate of two top officials